2009/1/16にfedora10のupdateの通知がきたので、updateを実施。
xineの依存関係のエラーがでる。

Transaction Check Error:
file /usr/share/locale/cs/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/de/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/eo/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/es/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/eu/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/fr/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/it/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/pl/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/pt_BR/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/sk/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/locale/tr/LC_MESSAGES/libxine1.mo conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
file /usr/share/man/man5/xine.5.gz conflicts between attempted installs of xine-lib-1.1.15-3.fc10.i386 and xine-lib-1.1.16-1.fc10.x86_64
	 

今回はgimpが2.6.4になったようなので、依存関係のエラー以外のupdateは全部取り込みたい。

# yum update --exclude=xine*

うまく取りこめたので再度updateをチェック

# yum check-update
xine-lib.x86_64                            1.1.16-1.fc10                 updates
xine-lib-pulseaudio.x86_64                 1.1.16-1.fc10                 updates

最初に見えた依存関係のエラーからi386関係の依存関係のエラーか

# yum update --exclude=*.i386 --enablerepo=updates-testing
--> Finished Dependency Resolution
xine-lib-extras-freeworld-1.1.15-4.fc10.x86_64 from installed has depsolving problems
--> Missing Dependency: xine-lib(plugin-abi) = 1.24 is needed by package xine-lib-extras-freeworld-1.1.15-4.fc10.x86_64 (installed)
Error: Missing Dependency: xine-lib(plugin-abi) = 1.24 is needed by package xine-lib-extras-freeworld-1.1.15-4.fc10.x86_64 (installed)
	 

新しいのがUPするまで、しばらく待つしかないみたい。